FluentAssertions 1.3.0.1

A very extensive set of extension methods for .NET 3.5, 4.0 and Silverlight 4.0 that allow you to more naturally specify the expected outcome of a TDD or BDD-style unit test.

There is a newer version of this package available.
See the version list below for details.
Install-Package FluentAssertions -Version 1.3.0.1
dotnet add package FluentAssertions --version 1.3.0.1
<PackageReference Include="FluentAssertions" Version="1.3.0.1" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add FluentAssertions --version 1.3.0.1
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

Dependencies

This package has no dependencies.

GitHub repositories (306)

Showing the top 5 popular GitHub repositories that depend on FluentAssertions:

Repository Stars
App-vNext/Polly
Polly is a .NET resilience and transient-fault-handling library that allows developers to express policies such as Retry, Circuit Breaker, Timeout, Bulkhead Isolation, and Fallback in a fluent and thread-safe manner. From version 6.0.1, Polly targets .NET Standard 1.1 and 2.0+.
restsharp/RestSharp
Simple REST and HTTP API Client for .NET
dotnet/machinelearning
ML.NET is an open source and cross-platform machine learning framework for .NET.
felixse/FluentTerminal
A Terminal Emulator based on UWP and web technologies.
IdentityServer/IdentityServer4
OpenID Connect and OAuth 2.0 Framework for ASP.NET Core

Version History

Version Downloads Last updated
3.3.0 87,017 2/18/2015
3.2.2 57,367 12/12/2014
3.2.1 76,745 9/11/2014
3.1.229 35,747 7/29/2014
3.0.107 44,859 4/30/2014
2.2.0 49,856 12/30/2013
2.1.0 28,903 8/23/2013
2.0.1 25,457 3/3/2013
2.0.0.1 10,678 10/15/2012
1.7.1.1 5,863 3/24/2012
1.7.0 478 1/13/2012
1.6.0 611 10/31/2011
1.5.0 536 6/29/2011
1.4.0 271 3/14/2011
1.3.0.1 193 1/15/2011
Show less